Polygon blockchain is experiencing a major outage

Incident Report for MoonPay

Resolved

Polygon blockchain is now operational
Posted Jul 30, 2025 - 15:11 UTC

Monitoring

Polygon Mainnet Blockchain is currently not operational and does not produce new blocks. We're currently monitoring the status, and will provide an update soon.
Posted Jul 30, 2025 - 12:26 UTC
This incident affected: Digital Currencies (Ethereum (Polygon)).